oXfoZ, webagency experte en technologies open-source

Firefox : versions 3.5.3 et 3.0.14 qui vérifient Flash

Dans le cadre de son processus de maintenance, la fondation Mozilla livre les versions 3.5.3 et 3.0.14 de son navigateur Firefox. Il s’agit de corriger plusieurs problèmes de stabilité dont la liste complète pourra être consultée ici pour Firefox 3.5.3 et là pour Firefox 3.0.14. Dans ces listes, on trouvera également trace de la correction de problèmes de sécurité.

Les problèmes de sécurité résolus sont partagés par les deux versions pour quatre d’entre eux, la version 3.0.14 ayant droit à la correction supplémentaire d’un problème qualifié de modéré. Parmi ces quatre bugs de sécurité corrigés, trois sont qualifiés de critiques et un de bas.

Vérification de Flash Player

Ces versions 3.5.3 et 3.0.14 inaugurent également une petite nouveauté puisqu’après mise à jour et premier lancement, Firefox prévient l’utilisateur si sa version de Flash Player est à jour. La vérification s’effectue via une page Web et le cas échéant, un lien dirige l’utilisateur vers le téléchargement de la dernière version de Flash Player.

La fondation Mozilla estime que des versions obsolètes de plugins représentent un risque important de sécurité avec également des problèmes potentiels de plantage et de stabilité. Flash Player d’Adobe essuie les plâtres du fait de sa popularité, alors que selon des chiffres cités par Mozilla, 80 % des utilisateurs disposent d’une version non à jour. Mozilla a toutefois déjà annoncé son intention de travailler avec d’autres éditeurs de plugins pour proposer un mécanisme de vérification similaire.

source et suite de l’article